Closed Thread Icon

Preserved Topic: Problem with Matt's FormMail (Page 1 of 1) Pages that link to <a href="http://ozoneasylum.com/backlink?for=21002" title="Pages that link to Preserved Topic: Problem with Matt&amp;#039;s FormMail (Page 1 of 1)" rel="nofollow" >Preserved Topic: Problem with Matt&#039;s FormMail <span class="small">(Page 1 of 1)</span>\

 
Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-01-2001 01:50

these are the on variables needed for me to configure the script:

code:
#!/usr/bin/perl

$mailprog = '/usr/sbin/sendmail'; #f2s says this is the path to sendmail on their server

@referers = ('allewyn.f2s.com','^davidh@hereigo.net','worldwidemart.com');

@recipients = @referers;

@valid_ENV = ('REMOTE_HOST','REMOTE_ADDR','REMOTE_USER','HTTP_USER_AGENT');



For some reason IE is sending back the message that "the file can't be found" the basic 404. I don't know a lot about cgi so I hope someone can tell me what I'm doing wrong.
www.allewyn.f2s.com/request_form.html <-- form location www.allewyn.f2s.com/FormMail.pl <-- the full script
edit: I also notice the file size is smaller after transfer, using ASCII mode. I've transfered it several times and it's always the same smaller size at the other end. Maybe there's a problem with their server?


[This message has been edited by Allewyn (edited 12-01-2001).]

bitdamaged
Maniac (V) Mad Scientist

From: 100101010011 <-- right about here
Insane since: Mar 2000

posted posted 12-01-2001 02:24

have you chmod'd the script to the proper permissions?

Usualy this will give a forbidden but it depends on the server.



:[ Computers let you make more mistakes faster than any other invention in human history, with the possible exceptions of handguns and tequila. ]:

Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-01-2001 02:48

Yah, don't have to chmod anything according to f2s www.freedom2surf.net/support/faq

I thought it was wierd myself. I agree, if the access privs aren't set properly, it won't work. In fact here's what they say

quote:
The file permissions are set automatically by the webserver so manual settings file permissions hsould not be needed.
Perl scripts have their file permissions set to 755 or -rwxr-xr-x.
Note: manually chmoding your scripts to make them group or world writable will result in your scripts failing to run properly.

Go figger. I don't get any errors from the script and I have the debugger enabled. Just the 404.

Do I have to supply the Perl version number as in /usr/bin/perl5.005_03 (f2s current version)?

[This message has been edited by Allewyn (edited 12-01-2001).]

[This message has been edited by Allewyn (edited 12-01-2001).]

JKMabry
Maniac (V) Inmate

From: out of a sleepy funk
Insane since: Aug 2000

posted posted 12-01-2001 03:02

the path you've specified for the perl script in your form tag is whackee, straighten that out and go from there...

Jason

mr.maX
Maniac (V) Mad Scientist

From: Belgrade, Serbia
Insane since: Sep 2000

posted posted 12-01-2001 09:57

Your FORM ACTION parameter is wrong... You should specify HTTP URL, not filesystem path to the script, like this:

<FORM METHOD="post" ACTION="http://www.allewyn.f2s.com/FormMail.pl">


Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-01-2001 14:49

Ok, thanks I'll give that a try
I wonder why they tell people that other stuff...

Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-01-2001 18:44

Sweet! It works Have to add redirects but the site is fully functional now. THANKS!

I don't know why f2s causes all that confusion...

mr.maX
Maniac (V) Mad Scientist

From: Belgrade, Serbia
Insane since: Sep 2000

posted posted 12-01-2001 19:46

How did f2s confuse you? They haven't said anything about what should go in ACTION parameter, and it is known that ACTION parameter accepts only URL as value...


Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-02-2001 17:16

AFter I log in, there's a page for website management, and at the bottom of the page this:

quote:
Your full directory path for use in cgi/php scripts is:
/web/sites/82/allewyn/www.allewyn.f2s.com



so, I assumed that "/web/sites/82/allewyn/www.allewyn.f2s.com/FormMail.pl" was the url to my cgi

[This message has been edited by Allewyn (edited 12-02-2001).]

mr.maX
Maniac (V) Mad Scientist

From: Belgrade, Serbia
Insane since: Sep 2000

posted posted 12-02-2001 17:54

That's local filesystem path (like "c:\www\html\blah" on Windows), which you should use in scripts that require from you to provide them with that info...


Allewyn
Maniac (V) Mad Scientist

From: Solitary confinement
Insane since: Feb 2001

posted posted 12-03-2001 23:09

Ok, thanks again for your help

« BackwardsOnwards »

Show Forum Drop Down Menu