Topic: Animated mask flicker problem (Page 1 of 1) Pages that link to <a href="http://ozoneasylum.com/backlink?for=29297" title="Pages that link to Topic: Animated mask flicker problem (Page 1 of 1)" rel="nofollow" >Topic: Animated mask flicker problem <span class="small">(Page 1 of 1)</span>\

 
reisio
Paranoid (IV) Inmate

From: Florida
Insane since: Mar 2005

IP logged posted posted 06-22-2007 18:49 Edit Quote

http://reisio.com/asdf/
http://reisio.com/asdf/asdf.fla

You'll probably notice that at the end of the animation when expanding (or the beginning when collapsing), there's an evil little flicker, like it has to reload the (blue) PNG images. If I remove the masks, though, there is no flicker...so my best guess is that somehow it's the masks' fault.

This is driving me batty - I'd really appreciate any help.

reisio
Paranoid (IV) Inmate

From: Florida
Insane since: Mar 2005

IP logged posted posted 06-25-2007 10:38 Edit Quote

Well I haven't really figured out how to do it cleanly yet, but I have hacked around the flicker. Close enough for now.

reisio
Paranoid (IV) Inmate

From: Florida
Insane since: Mar 2005

IP logged posted posted 06-26-2007 21:33 Edit Quote

I guess I should say how I hacked around it, in case someone comes looking for a solution, like me, and finds nothing.

The issue was an animated mask which forced reloads of other animations in the movie (and maybe itself) when it reached the keyframe at the end of its tweening. I just told the ActionScript handling the animation to not proceed after the frame immediately before the last keyframe, avoiding the issue entirely. I used an if statement with _currentframe < 10. Bit hacky, but I'm so happy to have that flickering gone.



Post Reply
 
Your User Name:
Your Password:
Login Options: Remember Me On This Computer
 
Your Text:
Loading...
Options: Show Signature
Enable Slimies
Enable Linkwords

« BackwardsOnwards »

Show Forum Drop Down Menu