Topic: Anchor link with background and hover not working in FF =( (Page 1 of 1) Pages that link to <a href="http://ozoneasylum.com/backlink?for=31562" title="Pages that link to Topic: Anchor link with background and hover not working in FF =( (Page 1 of 1)" rel="nofollow" >Topic: Anchor link with background and hover not working in FF =( <span class="small">(Page 1 of 1)</span>\

 
ensigncookie
Neurotic (0) Inmate
Newly admitted

From:
Insane since: Dec 2009

IP logged posted posted 12-28-2009 00:26 Edit Quote

i am currently designin a page for a friend and i added a background image that changes on hover to the page it shows perfect on IE but messed up on FF and Chrome


this is my css code:

#anchor1 {
width : 200px;
height : 35px;
background-image : url(epbutton.jpg);
font-size: large;
text-decoration: none;
text-align:center;
padding-left:25px
}
#anchor1:hover {
background-image : url(epbutton hover.jpg);



and this is the link i have using this anchor:

<td><a id="anchor1" href="joker">Free Sign-Up</a></td>

this link is in a tabel but for some reason it shows perfect in interenet explorer but thats only browser itll show perfect in this link can be found at:

http://international-pool-association.com/ep/

i hope someone can help me resolve this problem.

CPrompt
Maniac (V) Inmate

From: there...no..there.....
Insane since: May 2001

IP logged posted posted 12-28-2009 01:05 Edit Quote

needs height and width for one and I would not use a space in the name of an image. Add an underscore or dash in there or something
(epbutton_hover.jpg)

I don't have IE ATM so I can't see it working.

Later,

C:\

Slime
Lunatic (VI) Mad Scientist

From: Massachusetts, USA
Insane since: Mar 2000

IP logged posted posted 12-28-2009 03:14 Edit Quote

On Firefox, go to Tools -> Error Console. Clear the console and then refresh your page. You get one error:

Warning: Error in parsing value for property 'background-image'. Declaration dropped.
Source File: http://international-pool-association.com/ep/
Line: 18

It probably doesn't like the space in the URL. Maybe if you replace the space with %20 (the hex code for a space character) it will work?

background-image : url(epbutton%20hover.jpg);


 

ensigncookie
Obsessive-Compulsive (I) Inmate

From:
Insane since: Dec 2009

IP logged posted posted 12-28-2009 04:25 Edit Quote

took space out and nothing it does have a height and width specified in the anchor and added in image and nothing

CPrompt
Maniac (V) Inmate

From: there...no..there.....
Insane since: May 2001

IP logged posted posted 12-29-2009 02:09 Edit Quote

working here

Later,

C:\



Post Reply
 
Your User Name:
Your Password:
Login Options: Remember Me On This Computer
 
Your Text:
Loading...
Options: Show Signature
Enable Slimies
Enable Linkwords

« BackwardsOnwards »

Show Forum Drop Down Menu