Topic: opera bugs... (Page 1 of 1) Pages that link to <a href="https://ozoneasylum.com/backlink?for=11125" title="Pages that link to Topic: opera bugs... (Page 1 of 1)" rel="nofollow" >Topic: opera bugs... <span class="small">(Page 1 of 1)</span>\

 
jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

IP logged posted posted 01-06-2004 10:47 Edit Quote

well, the Ie bugs are fixed but now I have a few opera bugs that I'm trying to wire out. I have a huge gap between my content and footer. It's kind of strange, but it's even rendering an entire image incorrectly. In the header it's showing a big read box in place of the lightning part of the image?!. Also, apparently it doesn't like image rollovers the css way. Any clues or hints?
http://www.zerooneproductions.net/css/csstests/newindex.html






skyetyger
Bipolar (III) Inmate

From: midair
Insane since: Jul 2001

IP logged posted posted 01-07-2004 01:00 Edit Quote

Ok..for an UnOrdered List and for multiple unordered lists within a document..UL must be written Once.. ..in the script there must be a UL ..no period, no #.. write it ....*** ul {list-style-type: whatever; margin: 0px; padding 0px;***
The rollover does not work in IE6 either...I am not certain the way you wrote it ((a#home { left: 12px; background-image: url(images/home_up.gif);} )) will work but if you have an example of where it works, where you learned it.. a tutorial or a working example..?

You might look at this example, I believe it is correct..images can be substituted by changing the **background-color** to **background-image: url (whatever.gif}**....there is also a config/html, config1/html, config2/html ..illustrating the basic list rollover http://www.skyetyger.com/config3.html

There are also discussions over on the Guru's Network discussion board under CSS..If the a: and the lists are not written correctly there are very strange problems that occur..especially in Opera..I had some creative solutions to the UL problem before it was properly corrected by Paul

skyetyger
Bipolar (III) Inmate

From: midair
Insane since: Jul 2001

IP logged posted posted 01-07-2004 01:22 Edit Quote

The rollovers might be working..they are working if I change images ...I assume the plain grey without text is the rollover? It is an interesting way to do a rollover...It still needs the UL in the script if the UL is a rollover...not certain if it isn't a rollover..

jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

IP logged posted posted 01-08-2004 00:17 Edit Quote

Not working in IE 6?? Hmmmmm. It works here just fine on IE6. Although I am getting an initial blink on the rollover with some browsers. I learned how to do this from here:
http://www.alistapart.com/articles/imagemap/



skyetyger
Bipolar (III) Inmate

From: midair
Insane since: Jul 2001

IP logged posted posted 01-08-2004 20:08 Edit Quote

ALL RIGHT..Yes the rollover is working in IE6..I see the animation now..In Opera the rollover is working but the lettering is white and blurred..the lower portion of the content window is obscured by the footer..I have the same problem with a footer that is not encased in a very large Outer Container div on one of my pages..the footer will not align with flush with the content div in Opera as it does in IE and Firebird..You might post this in the Guru's discussion..The page works fine otherwise

[This message has been edited by skyetyger (edited 01-09-2004).]



Post Reply
 
Your User Name:
Your Password:
Login Options: Remember Me On This Computer
 
Your Text:
Loading...
Options: Show Signature
Enable Slimies
Enable Linkwords

« BackwardsOnwards »

Show Forum Drop Down Menu