Closed Thread Icon

Topic awaiting preservation: question about netscape 4.5 (Page 1 of 1) Pages that link to <a href="http://ozoneasylum.com/backlink?for=8242" title="Pages that link to Topic awaiting preservation: question about netscape 4.5 (Page 1 of 1)" rel="nofollow" >Topic awaiting preservation: question about netscape 4.5 <span class="small">(Page 1 of 1)</span>\

 
jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

posted posted 07-17-2002 18:24

Does netscape 4.5 recognize linked javascript files such as this:

<script language="JavaScript" src="slidermenu.js" type="text/javascript">

It doesn't seem to. It will however recognize it when I put the complete script in the header. Does netscape 4.5 not support linked javascript files?



Trigger
Paranoid (IV) Inmate

From:
Insane since: Jun 2002

posted posted 07-17-2002 18:30

Try
<script type="javascript" blah blah>

jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

posted posted 07-17-2002 18:36

what do you mean? like this?:

<script type="JavaScript" src="slidermenu.js" type="text/javascript">

I want the actual script in a .js file so I don't have to clutter up my page.

Slime
Lunatic (VI) Mad Scientist

From: Massachusetts, USA
Insane since: Mar 2000

posted posted 07-17-2002 18:42

no, type="javascript" is incorrect. Use either type="text/javascript" or the older and deprecated language="javascript".

In any case, NN4 does support this. It doesn't, however, allow you to document.write anything from the outside file. If you want to do this, make a function in the outside file that creates the text to be written, and then call that function from a script tag on the page like

document.write(getstufftobewritten());

Is it a document.write problem, or something else?

jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

posted posted 07-17-2002 19:15

Weird!! I just uploaded it here and I checked it on netscape 4.5 and it works when its uploaded and I go to the url. !? But I checked the same page on netscape 4.5 on my local machine and it doesn't show the menu... whats up with that? Also why are my links blue in netscape? won't it read my css?

CPrompt
Maniac (V) Inmate

From: there...no..there.....
Insane since: May 2001

posted posted 07-17-2002 19:58

When I looked at it in 4.7 there was no menu. That would be bad really IMHO.

As for the link colors, NN4 doesn't recognize the different colors for hover and visited.

Look in the CSS forum for a link that I posted there about the cross browser CSS issues.

Later,
C:\


~Binary is best~

jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

posted posted 07-17-2002 20:37

I know this is kinda dumb, but what does IMHO mean?

CPrompt
Maniac (V) Inmate

From: there...no..there.....
Insane since: May 2001

posted posted 07-17-2002 20:51

In my humble opinion.

Later,
C:\


~Binary is best~

jive
Paranoid (IV) Inmate

From: Greenville, SC, USA
Insane since: Jan 2002

posted posted 07-17-2002 21:38

is there really much of a difference between netscape 4.5 and netscape 4.7?

Hugh
Paranoid (IV) Inmate

From: Dublin, Ireland
Insane since: Jul 2000

posted posted 07-18-2002 03:34

Um, maybe ... maybe ... your leaving out the </script> its just you didnt write it in your example.

« BackwardsOnwards »

Show Forum Drop Down Menu