Topic: SOAP call response is a blank page (Page 1 of 1) Pages that link to <a href="https://ozoneasylum.com/backlink?for=31850" title="Pages that link to Topic: SOAP call response is a blank page (Page 1 of 1)" rel="nofollow" >Topic: SOAP call response is a blank page <span class="small">(Page 1 of 1)</span>\

 
Boudga
Maniac (V) Mad Scientist

From: Jacks raging bile duct....
Insane since: Mar 2000

IP logged posted posted 06-04-2010 16:43 Edit Quote

trying to do Hello World example SOAP call to Magento after creating my Magento user/role for API use and all I get is a blank page response even though a quick check of phpinfo shows I have SOAP enabled...any ideas folks?

Tyberius Prime
Maniac (V) Mad Scientist with Finglongers

From: Germany
Insane since: Sep 2001

IP logged posted posted 06-04-2010 17:25 Edit Quote

Does Magento redirect all it's php errors - check that file.
What happens when you visit the service url directly?

Boudga
Maniac (V) Mad Scientist

From: Jacks raging bile duct....
Insane since: Mar 2000

IP logged posted posted 06-04-2010 17:53 Edit Quote

I fixed it!

First I ssh'd into the machine and ran 'php soapcall.php' and realized from the results that the machine wasn't resolving this subdomain internally so I added the subdomain to the /etc/hosts file and then then I was able to make the SOAP call successfully.



Post Reply
 
Your User Name:
Your Password:
Login Options: Remember Me On This Computer
 
Your Text:
Loading...
Options: Show Signature
Enable Slimies
Enable Linkwords

« BackwardsOnwards »

Show Forum Drop Down Menu